В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
shcooltime
shcooltime
30.07.2021 15:06 •  Информатика

Напишите программу на Python.
"Найти количество четных цифр заданного натурального числа N."

Показать ответ
Ответ:
Piralta11
Piralta11
27.02.2021 19:20

while True:

 try:

   n = int(input('Введите натуральное число: '))

   break

 except ValueError:

   print('Неверные входные данные. Попробуйте снова.')

n = abs(n)

b = 0

while n>0:

 if n%10%2 == 0:

   b+=1

 n = n//10

print('Количество чётных цифр в ведённом числе равно ' + str(b))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота