В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
valentinasopina
valentinasopina
27.11.2021 20:39 •  Информатика

Напишите программу на с++ без динамических массивов с функцией Наименьшее общее кратное (НОК) двух натуральных чисел – это наименьшее число, которое делится нацело на оба исходных числа. Напишите программу, которая вычисляет НОК двух чисел. Используйте функцию.

Входные данные
Входная строка содержит два натуральных числа, разделённые пробелом – a и b .

Выходные данные
Программа должна вывести одно натуральное число: НОК заданных чисел.

Показать ответ
Ответ:
Артём244
Артём244
11.04.2021 19:50

надеюсь правильно

Объяснение:

#include <iostream>

using namespace std;

int gcd(int a, int b) {

   return (a == 0) ? b: gcd(b % a, a);

}

 

int main() {

   int n, m = 0;

   cin >> n;

   for (int i = 0; i < n; i++) {

       int a;

       cin >> a;

       m = gcd(m, a);

   }

   cout << m;

   return 0;

}

0,0(0 оценок)
Ответ:
meripet2005p08qlb
meripet2005p08qlb
11.04.2021 19:50

1

2

3

4

5

6

7

8

9

10

11

var m,n,pr:word;

begin

read(m,n);

pr:=m*n;

while m<>n do

begin

if m>n then m:=m-n

else n:=n-m

end;

write(pr div m)

end

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота