В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sasha16971
sasha16971
03.05.2021 23:11 •  Информатика

Напишите программу на с++
известна зарплата каждого из 12 работников фирмы за каждый месяц первого квартала (3 месяца) определите
а. общую сумму выплаченую всем работникам
б. зарплату полученую каждым работником за квартал
в. общую зарплату всех работников за каждый месяц

Показать ответ
Ответ:
provotorov2001
provotorov2001
03.09.2020 11:57

===== C++ 17 =====

#include <iostream>

using namespace std;

int main()

{

   srand(time(NULL));

   int n = 12, k = 3;

   int a[k][n];

   for(int i = 0; i < k; i++)

   {

       for(int j = 0; j < n; j++)

       {

           a[i][j] = (rand() % 35 + 25) * 1000;

           cout << a[i][j] << " ";

       }

       cout << endl;

   }

   cout << "\nОбщая сумма, выплаченная всем работникам: ";

   int s = 0;

   for(int i = 0; i < k; i++)

       for(int j = 0; j < n; j++)

           s += a[i][j];

   cout << s << "\nЗарплаты каждого работника за квартал:\n";

   s = 0;

   for(int j = 0; j < n; j++)

   {

       s = 0;

       for(int i = 0; i < k; i++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << "\nОбщие зарплаты всех работников по месяцам: ";

   for(int i = 0; i < k; i++)

   {

       s = 0;

       for(int j = 0; j < n; j++)

       {

           s += a[i][j];

       }

       cout << s << " ";

   }

   cout << endl;

   return 0;

}


Напишите программу на с++ известна зарплата каждого из 12 работников фирмы за каждый месяц первого к
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота