В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
hasanovratmir3
hasanovratmir3
18.03.2022 06:13 •  Информатика

Напишите программу на с++, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 3 и оканчивающихся на 9. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода,
не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. программа должна вывести одно число: сумму всех чисел, кратных 3 и оканчивающихся на 9.

Показать ответ
Ответ:
panteleevpetr67
panteleevpetr67
10.10.2020 05:13

#include <iostream>

using namespace std;

int main()

{

int a,S=0;

cin >> a;

while(a!=0)

{

if(a % 3 == 0 && a % 10 == 9) S=S+a;

cin >> a;

}

cout<<S;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота