Напишите программу на с++, которая вводит натуральное число n и выводит на экран все натуральные числы, не превосходящие n и делящуеся на каждую из своих цифр
int main() { int n; cin >> n; for (int i = 1; i <= n; ++i) { int tmp = i; bool fl = true; while (tmp) { int x = tmp % 10; if (x != 0) if (i % x != 0) fl = false; if (!x) fl = false; tmp /= 10; } if (fl) cout << i << ' '; } }
using namespace std;
int main()
{
int n; cin >> n;
for (int i = 1; i <= n; ++i)
{
int tmp = i;
bool fl = true;
while (tmp) {
int x = tmp % 10;
if (x != 0)
if (i % x != 0)
fl = false;
if (!x) fl = false;
tmp /= 10;
}
if (fl) cout << i << ' ';
}
}