В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
8алина82
8алина82
18.05.2021 00:58 •  Информатика

Напишите программу на с++, которая вводит последовательность целых чисел, заканчивающихся нулем, и определяет количество четных положительных чисел в этой последовательности

Показать ответ
Ответ:
Den2891
Den2891
07.10.2020 23:47
#include <iostream>
#include <iomanip>
using namespace std;

int main() {
   int n,k=0;
   for (int i=0; ;) {
     cin>>n;
     if (n==0) break;
     if (n%2==0 && n>0) k++;
   }  
   cout<<k<<endl;
   system("pause");
   return 0;
}

3 -15 -18 14 7 9 -12 10 0
2
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота