В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
School957
School957
14.10.2022 10:14 •  Информатика

Напишите программу на С++ Создать функцию типа void с передачей параметров по
ссылке или указателю, которая определяет длину отрезка
по его координатам. Для создаваемой функции необходимо
подобрать имя; выбрать имена и типы входных и выходных
параметров; описать тело функции; в главной программе
вызвать созданную подпрограмму более одного раза с
различными входными данными.

Показать ответ
Ответ:
На0вид0ангел
На0вид0ангел
03.08.2021 19:46

1) Если имя переменной в себе содержит больше одного слова, то оно всё равно целиком должно быть написано слитно, иначе SyntaxError

birth day -> BirthDay или birthDay или birth_day

2) # Step 3: if * > **: age = year - birth_year then:

    - Переменная birth_year ранее не объявлена

    - как интерпретатор должен осознать значение выражения " if * > ** " ?

    - Откуда там взялся then: ?

3) print("Your age: {a} years, {b} months, {c} days"):

    - Перед форматированной строкой должен стоять флаг f:

      print(f' value: {value}')

Вывод: Изучите основы синтаксиса Python

0,0(0 оценок)
Ответ:
Викарайс
Викарайс
28.09.2020 07:57

Язык Паскаль.

Program Ski;

const n=5; {длина массива}

var: a:array [1..n] of integer; i,s:integer;

begin

For i:=1 to n do begin

                          Writeln('vvedite element massiva nomer ',i);

                          Read(a[i]);

                        end;    {Тут мы просим пользователя ввести элементы}

s:=0; {s - это указанная тобой сумма. Мы ее соответственно обнуляем сначала}

for i:=1 to n do begin

                          if a[i] mod 10=0 then s:=s+a[i];  

                       end;    

 

{ берем каждый элемент массива, и проверяем, делится ли он на 10 без остатка(mod- это остаток от деления на указанное число). Если все в порядке, тогда прибавляем число к общей сумме }

 

Writeln('summa elementov ravnih nulu ',s);  {пишет ответ}

readln; {чтобы сразу не закрывалась программа}

end.

 

Если возникнут вопросы или появится еще подобное задание для решения, пиши прямо в личку. Мне все равно делать нечего )

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота