Напишите программу на с++, желательно без вектора Введите матрицу 5x5 целых чисел от 0 до 9. Если количество повторов элемента матрицы совпадает с самим элементом, то заменить его на нуль
Var a:integer; begin write('Введите время='); readln(a); if a=0 then begin write('Ночь'); end; if a=1 then begin write('Ночь'); end; if a=2 then begin write('Ночь'); end; if a=3 then begin write('Ночь'); end; if a=4 then begin write('Ночь'); end; if a=5 then begin write('Утро'); end; if a=6 then begin write('Утро'); end; if a=7 then begin write('Утро'); end; if a=8 then begin write('Утро'); end; if a=9 then begin write('Утро'); end; if a=10 then begin write('Утро'); end; if a=11 then begin write('День'); end; if a=12 then begin write('День'); end; if a=13 then begin write('День'); end; if a=14 then begin write('День'); end; if a=15 then begin write('День'); end; if a=16 then begin write('День'); end; if a=17 then begin write('Вечер'); end; if a=18 then begin write('Вечер'); end; if a=19 then begin write('Вечер'); end; if a=20 then begin write('Вечер'); end; if a=21 then begin write('Вечер'); end; if a=22 then begin write('Ночь'); end; if a=23 then begin write('Ночь'); end; if a=24 then begin write('Ночь'); end; end.
Есть формула: V = HWC/8 2килобайт разбор решения: 1)H - высота, равная 256 или 2 в восьмой степени 2) W - ширина, равная 256 или 2 в восьмой степени 3) C = 5, потому что есть другая формула , где N - это количество цветов. Количество цветов 28. Но нужно выбрать целое i по формуле i в битах. Нет такой степени чтобы 2 равнялась 28 поэтому берем ближайшую степень 5 и вставляем её в самую первую формулу. 4) Разделить на 8 нужно, чтобы перевести получившиеся биты в байты, но нам нужны килобайты, поэтому делим получившееся число на и получается нужный нам ответ в килобайтах.
a:integer;
begin
write('Введите время=');
readln(a);
if a=0 then begin
write('Ночь');
end;
if a=1 then begin
write('Ночь');
end;
if a=2 then begin
write('Ночь');
end;
if a=3 then begin
write('Ночь');
end;
if a=4 then begin
write('Ночь');
end;
if a=5 then begin
write('Утро');
end;
if a=6 then begin
write('Утро');
end;
if a=7 then begin
write('Утро');
end;
if a=8 then begin
write('Утро');
end;
if a=9 then begin
write('Утро');
end;
if a=10 then begin
write('Утро');
end;
if a=11 then begin
write('День');
end;
if a=12 then begin
write('День');
end;
if a=13 then begin
write('День');
end;
if a=14 then begin
write('День');
end;
if a=15 then begin
write('День');
end;
if a=16 then begin
write('День');
end;
if a=17 then begin
write('Вечер');
end;
if a=18 then begin
write('Вечер');
end;
if a=19 then begin
write('Вечер');
end;
if a=20 then begin
write('Вечер');
end;
if a=21 then begin
write('Вечер');
end;
if a=22 then begin
write('Ночь');
end;
if a=23 then begin
write('Ночь');
end;
if a=24 then begin
write('Ночь');
end;
end.
2килобайт
разбор решения:
1)H - высота, равная 256 или 2 в восьмой степени
2) W - ширина, равная 256 или 2 в восьмой степени
3) C = 5, потому что есть другая формула , где N - это количество цветов. Количество цветов 28. Но нужно выбрать целое i по формуле i в битах. Нет такой степени чтобы 2 равнялась 28 поэтому берем ближайшую степень 5 и вставляем её в самую первую формулу.
4) Разделить на 8 нужно, чтобы перевести получившиеся биты в байты, но нам нужны килобайты, поэтому делим получившееся число на и получается нужный нам ответ в килобайтах.