В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
яблоко50
яблоко50
15.09.2022 12:29 •  Информатика

Напишите программу, на вход которой подается одна строка с целыми числами. Программа должна вывести сумму этих чисел. Используйте метод split строки.

Sample Input:

4 -1 9 3
Sample Output:

15

Показать ответ
Ответ:
кусака22
кусака22
22.07.2020 01:04
В восьмеричную
2005 : 8 = 250, остаток 5
250 : 8 = 31, остаток 2
31 : 8 = 3, остаток 7
3 : 8 = 0, остаток 3
Выписываем остатки в обратном порядке: 3725

В пятеричную
2005 : 5 = 401, остаток 0
401 : 5 = 80, остаток 1
80 : 5 = 16, остаток 0
16 : 5 = 3, остаток 1
3 : 5 = 0, остаток 3
Выписываем остатки в обратном порядке: 31010

В двоичную
2005 : 2 = 1002, остаток 1
1002 : 2 = 501, остаток 0
501 : 2 = 250, остаток 1
250 : 2 = 125, остаток 0
125 : 2 = 62, остаток 1
62 : 2 = 31, остаток 0
31 : 2 = 15, остаток 1
15 : 2 = 7, остаток 1
7 : 2 = 3, остаток 1
3 : 2 = 1, остаток 1
1 : 2 = 0, остаток 1
Выписываем остатки в обратном порядке: 11111010101
0,0(0 оценок)
Ответ:
Yuiyuii
Yuiyuii
31.10.2022 19:56
// PascalABC.NET 3.0, сборка 1128
begin
  var b:array[,] of integer:=((5,8,7,3),(-2,0,6,9),(2,1,12,4));
  Writeln('Массив B: ',b);
  var n:=b.GetLength(0);
  var m:=b.GetLength(1);
  var imax:=0; var jmax:=0;
  var imin:=0; var jmin:=0;
  for var i:=0 to n-1 do
    for var j:=0 to m-1 do
      if b[i,j]>b[imax,jmax] then begin imax:=i; jmax:=j end
      else
        if b[i,j]<b[imin,jmin] then begin imin:=i; jmin:=j end;
  Swap(b[imin,jmin],b[imax,jmax]);
  Writeln('Результирующий массив: ',b)
end.

Тестовое решение:
Массив B: [[5,8,7,3],[-2,0,6,9],[2,1,12,4]]
Результирующий массив: [[5,8,7,3],[12,0,6,9],[2,1,-2,4]]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота