Напишите программу на языке c++, которая определяет, будет ли k-й день выходным, если 1 января - понедельник. требуется вывести "yes", если этот день выходной, "no" если нет.
Если друг оказался вдруг И не друг, и не враг, а - так, Если сразу не разберешь, Плох он или хорош, - Парня в горы тяни - рискни! Не бросай одного его, Пусть он в связке в одной с тобой - Там поймешь, кто такой.
Если парень в горах - не ах, Если сразу раскис и - вниз, Шаг ступил на ледник и - сник, Оступился - и в крик, - Значит, рядом с тобой - чужой, Ты его не брани - гони: Вверх таких не берут, и тут Про таких не поют.
Если ж он не скулил, не ныл, Пусть он хмур был и зол, но - шел, А когда ты упал со скал, Он стонал, но - держал, Если шел за тобой, как в бой, На вершине стоял хмельной, - Значит, как на себя самого, Положись на него.
//g++ -Wall -o 1 1.cpp
//./1
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int main() {
int n;
cin>>n;
if (n == 0){
cout<<0;
return 0;
}
else{
int a1 = 0 , a2 = 1;
int c = 1;
while(a2<=n){
if (a2==n){
cout<<c;
return 0;
}
a1 = a2;
a2 = a1+a2;
c++;
}
cout<<-1;
return 0;
}
}
Объяснение:
И не друг, и не враг, а - так,
Если сразу не разберешь,
Плох он или хорош, -
Парня в горы тяни - рискни!
Не бросай одного его,
Пусть он в связке в одной с тобой -
Там поймешь, кто такой.
Если парень в горах - не ах,
Если сразу раскис и - вниз,
Шаг ступил на ледник и - сник,
Оступился - и в крик, -
Значит, рядом с тобой - чужой,
Ты его не брани - гони:
Вверх таких не берут, и тут
Про таких не поют.
Если ж он не скулил, не ныл,
Пусть он хмур был и зол, но - шел,
А когда ты упал со скал,
Он стонал, но - держал,
Если шел за тобой, как в бой,
На вершине стоял хмельной, -
Значит, как на себя самого,
Положись на него.