Напишите программу на языке pascal.
братья вупсень и пупсень хотят стать бизнес-гусеницами. для этого украли у лунтика n
камней и только уже хотели начать свой мегабизнес, как тут вышла проблема - вупсень и пупсень стали решать кто будет боссом, из-за чего и поссорились.
чтобы выбрать кто будет боссом, они решили сыграть в одну странную игру. есть n
камней, которые они украли у лунтика. за каждый ход игрок может взять 1, 2 или 6 камней из кучки. кто не может сделать ход - проигрывает. так как вупсень старше пупсеня, вупсень ходит первым. мимо проходил лунтик и заинтересовался судьбой их многообещающего бизнеса при оптимальной игре обеих сторон.
лунтику узнать, кто будет командовать гусеничным !
2. integer
3. sqrt(число)
4. var
5. 16
6. 2
7.
function x(a,b,c:integer);
begin
x:=-b+sqr(b)-sqr(4*a*c)*a;
end;
8. 11
9. end.
10. d)
11.
var a,b,c:integer;
result:real;
begin
readln(a,b,c);
result:=(a*b*c)/3;
writeln(result:0:3);
end.
12. real
13. оператор присвоения
14. Присвоить переменной F значение 125
15. write(B); или writeln(B);
16. корень из суммы квадрата х и ста делить на разность а и b умноженной на с
17. с)
18. Нет картинки как образован массив, значит сами решите
19. d)
20. c)
21. c)
Создаём массив из 11 элементов, который называем Dat:
целтаб Dat[1:11]Объявляем переменные к и ш, являющимися целыми числами:
цел к, шЗаполняем массив Dat:
Dat[1]:=21 Dat[4]:=19 Dat[7]:=23 Dat[10]:=29 Dat[2]:=23 Dat[5]:=25 Dat[8]:=21 Dat[11]:=19 Dat[3]:=20 Dat[6]:=22 Dat[9]:=22Присваиваем переменной ш значение 0.
ш:=0Объявляем цикл от 1 до 11, то бишь пробегаемся по массиву Dat и смотрим, если значение элемента больше 22, то прибавляем к переменной ш 1:
нц для к от 1 до 11 если Dat[к]>22 то ш:=ш+1 Все кцВыводим на экран значение переменной ш:
вывод шТаким образом мы видим, что программа подсчитывает количество классов в которых больше 22 учеников. Таких классов будет 4: 2(23), 5(25), 7(23) и 10(29).