В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dianamihalenko9
dianamihalenko9
27.09.2020 13:51 •  Информатика

Напишите программу на языке Pascal. Дано натуральное число A, в записи которого нет нулей. Требуется найти минимальное двузначное число, которое можно увидеть в записи числа A. Например, для числа 815943 ответом будет 15.​

Показать ответ
Ответ:
ququqhbqha
ququqhbqha
12.10.2020 17:03

===Pascal ABC.Net===

program ;

var

 number, min, temp :integer;

begin

 min := 100;

 Write('Введите число без нулей: ');

 ReadLn(number);

 while number <> 0 do

 begin

   temp := number mod 100;

   if (temp < min) and (temp div 10 <> 0) then min := temp;

   number := number div 10;

 end;

 Write('Минимальное двузначное число: ', min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота