В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу на языке pascal дано: натуральное число -n выяснить с цикла repeat является ли оно простым (то есть делится на 1 и на само себя)

Показать ответ
Ответ:
Apelsinka0986
Apelsinka0986
06.10.2020 08:01
Var
  i, n: integer;
 
begin
  i := 1;
  read(n);
  repeat
    i := i + 1;
    if(n mod i = 0) and (n <> i) or (n = 1) then
      begin
       write('Число ', n, ' не является простым');
       exit;
      end;
  until i = trunc(sqrt(n)) + 1;
  write('Число ', n, ' является простым');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота