В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
russilian
russilian
26.02.2020 17:35 •  Информатика

Напишите программу на языке pascal.элементы массива а, удовлетворяющие условию а(i)> 5.5, переписать в массив в, а элементы, удовлетворяющие условию а(i)< =5.5, переписать в массив с. в массиве а m элементов.

Показать ответ
Ответ:
musmus11
musmus11
12.07.2020 12:33
 var
  A,B,C: array[1..100] of integer;
  i,n,j,k:integer;
begin
randomize;
j:=0;
k:=0;
Readln(n);
Writeln('Исходный массив:');
 for i:=1 to n do
  begin
   A[i]:=random(10);
   writeln('A[',i,']=',A[i]);
   end;
for i:=1 to n do
   if A[i]>5.5
    then  
     begin
       j:=j+1;
       B[j]:=A[i];
      end;
 for i:=1 to n do
  if A[i]<=5.5
  then 
    begin
     K:=k+1;
     C[k]:=A[i];
    end;
for i:=1 to j do
 writeln('B[',i,']=', B[i]);
for i:=1 to k do
 writeln('C[',i,']=', C[i]);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота