В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Pedors
Pedors
01.08.2021 09:00 •  Информатика

Напишите программу на языке паскаль как найти корни квадратного уравнения ( ax+bx+c=0 ),при этом использовав if then else со значениями дискрименанта d=0 d< 0 b d> 0

Показать ответ
Ответ:
макс3113
макс3113
02.08.2020 19:32
Var 
a, b, c, D: real;
  x1, x2: real;
begin
  Write('Введите А:'); Readln(a);
  Write('Введите B:'); Readln(b);
  Write('Введите C:'); Readln(c);
  D := sqr(b) - (4 * a * c);
  if (D > 0) then
 begin
    x1 := (-b + sqrt(D)) / (2 * a);
    x2 := (-b - sqrt(D)) / (2 * a);
    Writeln('x1=', x1);
    Writeln('x2=', x2);  end  else
   if(d = 0) then
 begin
    x1 := b / (2 * a);
    Write('x1=', x1, 'x2=', x1);
  end   else
 writeln('Корней нет');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота