В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Yurk15
Yurk15
17.12.2020 04:44 •  Информатика

Напишите программу на языке Паскаль, которая при вводе положительного числа утраивает его значение, при вводе отрицательного числа увеличивает его на 10 единиц, при вводе 0 уменьшает его на 2 единицы.

Показать ответ
Ответ:
ArkhamCity
ArkhamCity
13.10.2020 08:06

pascal

Объяснение:

program prog1;

var

 a: real;

begin

 Write('Введите число ');

 ReadLn(a);

 if a > 0 then a := a *3

 else if a < 0 then a := a + 10

 else a := a - 2;

 Write('a = ', a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота