В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
13372225
13372225
19.08.2020 14:24 •  Информатика

Напишите программу на языке паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.программа получает на выход целые числа. количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность ).количество чисел не превышает 20. введенные числа [-30; 30]. программа должна вывести одно число: количество четных чисел, кратных 3. буду признательна!

Показать ответ
Ответ:
Мику35
Мику35
14.08.2020 18:16
Program n1;
const n=20;
var a: array [1..n] of integer;
i,k: integer;
begin
k:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
if (a[i]=0) or (a[i]<=-30) or (a[i]>=30) then break;
if (a[i] mod 2=0) and (a[i] mod 3=0) then k:=k+1;
end;
writeln('количество: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота