В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
perrybazinga
perrybazinga
02.06.2022 09:20 •  Информатика

Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.

Показать ответ
Ответ:
lchayanb17
lchayanb17
01.10.2020 16:53
Var
    i, s1, s2, s3, s4, n: integer;

begin
    write('n = ');
    readln(n);
    s1 := 0;
    s2 := 0;
    s3 := 0;
    s4 := 0;
    
    for i := 1 to n do
    begin
        s1 := s1 + i;
        s2 := s2 + sqr(i);
        if i mod 2 = 0 then s3 := s3 + i;
    end;
    
    for i := 10 to 99 do s4 := s4 + i;
    
    writeln('Сумма первых n натуральных чисел: ', s1);
    writeln('Сумма квадратов первых n натуральных чисел: ', s2);
    writeln('Сумма всех четных чисел: ', s3);
    writeln('Сумма всех двухзначных чисел: ', s4);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота