В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
shazzoap00xhr
shazzoap00xhr
21.08.2021 15:21 •  Информатика

Напишите программу на языке паскаль! с клавиатуры вводится три четырёх значных числа. найти сумму нечётных цифр в наименьшем числе.

Показать ответ
Ответ:
xatovaan
xatovaan
06.10.2020 13:38
Var
  a, b, c, sum: integer;

function min(x, y: integer): integer;
begin
  if(x > y) then result := y
  else result := x;
end;
 
begin
  sum := 0;
  read(a, b, c);
  a := min(a, min(b, c));
  while a > 0 do
  begin
    if(a mod 10 mod 2 <> 0) then sum := sum + a mod 10;
    a := a div 10;
  end;
  write(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота