Напишите программу на языке Паскаля вычисляет стоимость покупки в магазине для определения будем считать что в покупаемый набор входят апельсины и яблоки с клавиатуры вводятся: стоимость 1 кг апельсинов ; стоимость 1 кг яблок; вес апельсина и яблок
1. Всего этажей 8, значит, для идентификации каждого этажа достаточно 3 бит данных. (2^3 = 8)
Всего этажей 8, значит, для идентификации каждого этажа достаточно 3 бит данных. (2^3 = 8)Указание одного единственного этажа при таком раскладе занимает 3 бита.
Всего этажей 8, значит, для идентификации каждого этажа достаточно 3 бит данных. (2^3 = 8)Указание одного единственного этажа при таком раскладе занимает 3 бита.ответ: 3 бита.
2. Используем формулу 2^i=N. Так как в алфавите 16 символов (N=16), то 2^i=16, следовательно i=4. 4 бита весит один символ. 384*4=1536. 1536 бит весит сообщение из 384 символов по 4 бита каждый. Переводим биты в байты. 1 байт=8 бит, 1536/8=192 байта. Переводим байты в килобайты. 1 килобайт=1024 байт. 192/1024=0,1875 килобайт весит все сообщение. Так что лучше ответ оставить в байтах (192 байта).
3. Мощность алфавита - это количество символов, из которых состоит алфавит.
Мощность алфавита - это количество символов, из которых состоит алфавит.26 букв латинского *2= 52 символа и 5 основных знаков арифм операций = 52+5=57 символов -ответ
Var f,s:text; st,sp:string; i:integer; c:char; begin assign(s,'text1.txt'); reset(s); while not Eof(s) do begin; readln(s,sp); st:=st+sp+chr(10)+chr(13); end; close(s); for i:=1 to length(st) div 2 do begin c:=st[i]; st[i]:=st[length(st)-i+1]; st[length(st)-i+1]:=c; end; assign(f,'text.txt'); rewrite(f); write(f,st); close(f); end.
Текст в файле text1.txt:
Simple text 1And another simple text 2New text
Текст в файле text.txt: txet weN2 txet elpmis rehtona dnA1 txet elpmiS
1. Всего этажей 8, значит, для идентификации каждого этажа достаточно 3 бит данных. (2^3 = 8)
Всего этажей 8, значит, для идентификации каждого этажа достаточно 3 бит данных. (2^3 = 8)Указание одного единственного этажа при таком раскладе занимает 3 бита.
Всего этажей 8, значит, для идентификации каждого этажа достаточно 3 бит данных. (2^3 = 8)Указание одного единственного этажа при таком раскладе занимает 3 бита.ответ: 3 бита.
2. Используем формулу 2^i=N. Так как в алфавите 16 символов (N=16), то 2^i=16, следовательно i=4. 4 бита весит один символ. 384*4=1536. 1536 бит весит сообщение из 384 символов по 4 бита каждый. Переводим биты в байты. 1 байт=8 бит, 1536/8=192 байта. Переводим байты в килобайты. 1 килобайт=1024 байт. 192/1024=0,1875 килобайт весит все сообщение. Так что лучше ответ оставить в байтах (192 байта).
3. Мощность алфавита - это количество символов, из которых состоит алфавит.
Мощность алфавита - это количество символов, из которых состоит алфавит.26 букв латинского *2= 52 символа и 5 основных знаков арифм операций = 52+5=57 символов -ответ
Объяснение:
(Баал классная)
Var
f,s:text;
st,sp:string;
i:integer;
c:char;
begin
assign(s,'text1.txt');
reset(s);
while not Eof(s) do
begin;
readln(s,sp);
st:=st+sp+chr(10)+chr(13);
end;
close(s);
for i:=1 to length(st) div 2 do
begin
c:=st[i];
st[i]:=st[length(st)-i+1];
st[length(st)-i+1]:=c;
end;
assign(f,'text.txt');
rewrite(f);
write(f,st);
close(f);
end.
Текст в файле text1.txt:
Simple text
1And another simple text
2New text
Текст в файле text.txt:
txet weN2
txet elpmis rehtona dnA1
txet elpmiS