В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Ol3ksa
Ol3ksa
28.01.2020 00:00 •  Информатика

Напишите программу на языке питон, которая получает с клавиатуры четырёхзначное число и находит сумму цифр числа

Показать ответ
Ответ:
EkaterinaZeyb
EkaterinaZeyb
28.03.2021 08:04

Вместе chislo можно поставить любую букву, просто мне так нравится

Объяснение:

chislo =int(input())

print(chislo%10 + chislo//10%10+ chislo //100%10+chislo//1000)

0,0(0 оценок)
Ответ:
Nastusha21032005
Nastusha21032005
28.03.2021 08:04

num = abs(int(input()))

_sum = 0

while num > 0:

   _sum += num % 10

   num //= 10

print(_sum)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота