Напишите программу на языке программирования C ++, которая будет реализовывать следующие действия: 1. Отобразите следующие числа с двухциклового оператора:
10,9,8,7,6,5,4,3,2,1
9,8,7,6,5,4,3,2,1
8,7,6,5,4,3,2,1
7,6,5,4,3,2,1
…
2.1
1
Примечание. Всего должно быть выведено 10 строк.
2. Введите строку текста с клавиатуры. Вывести символы этой строки (по одному) на экран в случае заказа.
3. Реализуйте алгоритм, в котором пользователь входит в область прямоугольника - целое число. Программа отображает края всех возможных прямоугольников, которые являются целыми числами.
4. Реализуйте алгоритм, в котором пользователь выбирает случайное число в диапазоне от 1 до 1000, а программа пытается его угадать. Программа выводит возможное правильное число, на которое пользователь может ответить: «число больше» или «число меньше», пока программа не выведет правильное число. С каждым ответом пользователя программа сужает диапазон возможных правильных чисел.
#include <iostream>
int main()
{
using namespace std;
int N;
cout << "Enter N: ";
cin >> N;
int num;
int max = 1;
int i;
for (i = 0; i < N; ++i)
{
cout << "Enter #" << i + 1 << " number: ";
cin >> num;
if ((num - 9) % 10 != 0 && num % 3 == 0)
{
max = num;
break;
}
}
for (int j = i + 1; j < N; ++j)
{
cout << "Enter #" << j + 1 << " number: ";
cin >> num;
if ((num - 9) % 10 != 0 && num % 3 == 0)
if (num > max)
max = num;
}
if (max != 1)
cout << "Max number div by 3 and don't end 9: " << max << endl;
else
cout << "No numbers div by 3 and don't end 9" << endl;
return 0;
}
begin
var s:=ReadLines('in.txt').ToArray;
var n:=StrToInt(s[0]);
var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
var f:=OpenWrite('out.txt');
Writeln(f,n,' - (кол-во чисел)');
foreach var e in a do Write(f,e,' '); Writeln(f);
Writeln(f,'Среднее значение четных ',
a.Where(x->x.IsEven).Average);
Writeln(f,'Среднее значение нечетных ',
a.Where(x->x.IsOdd).Average);
f.Close
end.
Файлы in.txt и out.txt находятся во вложении.
Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25