В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KamilyaG
KamilyaG
03.02.2023 08:26 •  Информатика

Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляет А^N без использования операции возведения в степень.

Показать ответ
Ответ:
AishaZamyjem8
AishaZamyjem8
12.10.2020 01:32

a = int(input())

n = int(input())

a1 = a

for k in range (n - 1) :

   a *= a1

print (a)

Объяснение:

Мы вводим два числа и начинаем цикл While, в котором мы каждый раз когда делаем возведение в степень (умножаем число А на самого себя) уменьшаем число N (значащее степень, в которую надо возвести число)

Прикладываю базовые тесты:


Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота