В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу на языке си. дан текст произвольной длины оканчивающийся точкой c запятой. подсчитать количество “: =” в тексте

Показать ответ
Ответ:
gameshow34
gameshow34
06.10.2020 13:59
#include <stdio.h>

int main(void) {
char c1,c2;
int k=0;
printf("Вводите символы (в конце ';')\n");
scanf("%c",&c2);
do {
c1 = c2;
scanf("%c",&c2);
if ((c1 == ':')&&(c2 == '=')) k++;
}
while (c2 != ';');
printf("k = %d",k);
return 0;
}

Пример:
Вводите символы (в конце ';') 
i:=0, s:=0;
k = 2
0,0(0 оценок)
Ответ:
викуха308
викуха308
06.10.2020 13:59
:=;"
  int
    i = 1,
    cnt = 0;

  if (str[0] == ';')
    return;
  
  while (str[i] != ';')
  {
    if (str[i - 1] == ':' && str[i] == '=')      cnt++;    i++;  }

  printf("%i\n", cnt);
  _getch();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота