В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
miran3
miran3
10.11.2020 01:36 •  Информатика

Напишите программу на языке си. дана последовательность целых чисел и количество членов в последовательности. вычислите есть ли число 0 в поледовательности

Показать ответ
Ответ:
laralarisa
laralarisa
26.08.2020 19:22
#include <stdio.h>
#include <stdlib.h>

int main() 

   int n, f=0;
   scanf ("%d", &n); 
   int a[n]; 

   srand (time(NULL));  
   for (int i = 0; i < n; i++ )  
   {
    a[i] = rand() % 20 -10;
    printf ("%4d ", a[i]);
   }
    printf("\n");
   for (int i = 0; i < n; i++ )  
    if (a[i]==0) f++;
   if (f>0) printf("YES");
   else printf("NO");
    return 0;
}

Пример:
10
-1 -4 0 1 2 5 -7 -8 5 6
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота