В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kuznecovaalexa2005
Kuznecovaalexa2005
27.06.2021 19:00 •  Информатика

Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел)

Показать ответ
Ответ:
Апельсинка102
Апельсинка102
23.06.2020 20:27
Var
    a, b, c, d: integer;

function max(i1, i2: integer): integer;
begin
    if i1 > i2 then max := i1 else max := i2;
end;

begin
    read(a, b, c, d);
    writeln(max(max(max(a, b), c), d));
end.

не помню как процедуры писать, но с функциями даже удобнее
0,0(0 оценок)
Ответ:
лолкек66
лолкек66
23.06.2020 20:27
Program ufhg;
uses crt;
var a,b,c,d, m: integer;
begin 
readln(a,b,c,d);
m:=a;
if(b>m) then m:=b;
if(c>m) then m:=c;
if(d>m) then m:=d;
writeln(m);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота