Напишите программу(pascal), которая рисует эллипс, вытянутый по оси y, причем координаты центра, радиус, коэффициент сжатия и цвет контура вводятся с клавиатуры.
Чтобы найти площадь равнобедренного треугольника, необходимо знать его основные свойства.
Существует три свойства, необходимые для вычислительных действий:
Углы, которые находятся напротив равных сторон геометрической фигуры, также равны по отношению друг к другу. Биссектрисы, высоты и медианы, которые будут проведены из этих углов, тоже будут равными.
Если провести биссектрису, высоту, медианы и начертить срединный перпендикуляр, проходящий по центральной точке основания, то они совпадут между собой. На этой линии будут лежать центры описанной и вписанной в треугольник окружностей.
Углы по обеим сторонам основания идентичны друг другу.
Для этого необходимо узнать, чему равно произведение половины основания и высоты.
Но как быть, если высота или длина основания неизвестны? Рассмотрим несколько примеров вычисления неизвестных составляющих для нахождения площади равнобедренного треугольника.
Если вам известна длина основания и длина боковой стороны, можно воспользоваться теоремой Пифагора (а2+b2=с2), чтобы найти высоту. Поскольку боковая сторона является гипотенузой, а ½ основания – катетом, можно запросто узнать необходимое значение.
Если вы знаете, чему равна длина основания и сколько градусов составляет угол между основанием и боковой стороной, этого вполне достаточно, чтобы найти площадь равнобедренного треугольника. Из соотношения сторон по формуле h=c*ctg(B)/2 необходимо найти высоту, поделив сторону с на две части. После этого у вас будут все необходимые значения.
Если вам дана высота и угол между основанием и одной из боковых сторон, сперва следует найти высоту из соотношения двух сторон фигуры по формуле c=h*tg(B)*2. Полученный результат будет являться половиной основания, следовательно, его нужно удвоить. После этого можно узнать площадь по формуле, приведенной выше.
var
a, n: longint;
text: textfile;
function myMod(num, power, divider: longint): longint;
var
rest, i: longint;
begin
rest:=1;
divider := abs(divider);
for i := 1 to power do
begin
rest := rest * num;
rest := rest mod divider;
end;
myMod := rest;
end;
begin
assign(text, 'input.txt');
{rewrite(text);
writeln(text, 1);
close(text);}
reset(text);
read(text, a);
writeln('a=', a);
close(text);
n := 0;
repeat
n := n + 1;
until MyMod(n, n, a) = 0;
writeln('n=', n);
assign(text, 'output.txt');
rewrite(text);
writeln(text, n);
close(text);
{reset(text);
read(text, n);
writeln('n=', n);
close(text);}
end.
Чтобы найти площадь равнобедренного треугольника, необходимо знать его основные свойства.
Существует три свойства, необходимые для вычислительных действий:
Углы, которые находятся напротив равных сторон геометрической фигуры, также равны по отношению друг к другу. Биссектрисы, высоты и медианы, которые будут проведены из этих углов, тоже будут равными.
Если провести биссектрису, высоту, медианы и начертить срединный перпендикуляр, проходящий по центральной точке основания, то они совпадут между собой. На этой линии будут лежать центры описанной и вписанной в треугольник окружностей.
Углы по обеим сторонам основания идентичны друг другу.
Для этого необходимо узнать, чему равно произведение половины основания и высоты.
Но как быть, если высота или длина основания неизвестны? Рассмотрим несколько примеров вычисления неизвестных составляющих для нахождения площади равнобедренного треугольника.
Если вам известна длина основания и длина боковой стороны, можно воспользоваться теоремой Пифагора (а2+b2=с2), чтобы найти высоту. Поскольку боковая сторона является гипотенузой, а ½ основания – катетом, можно запросто узнать необходимое значение.
Если вы знаете, чему равна длина основания и сколько градусов составляет угол между основанием и боковой стороной, этого вполне достаточно, чтобы найти площадь равнобедренного треугольника. Из соотношения сторон по формуле h=c*ctg(B)/2 необходимо найти высоту, поделив сторону с на две части. После этого у вас будут все необходимые значения.
Если вам дана высота и угол между основанием и одной из боковых сторон, сперва следует найти высоту из соотношения двух сторон фигуры по формуле c=h*tg(B)*2. Полученный результат будет являться половиной основания, следовательно, его нужно удвоить. После этого можно узнать площадь по формуле, приведенной выше.
http://otvetkak.ru/other-advice/ploshhad-ravnobedrennogo-treugolnika.html