В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Айка12341
Айка12341
16.01.2023 03:37 •  Информатика

Напишите программу(паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр : с

Показать ответ
Ответ:
oksa7610
oksa7610
05.07.2020 06:47
Var
n, k, a, i: integer;

begin
write('Введите кол-во чисел: ');
readln(n);
for i:=1 to n do
 begin
 read(a);
 if ((a mod 2) = 1) then inc(k);
end;
write(k);
end.

С использованием оператора repeat:

var
n, k, a, i: integer;
begin
write('Введите кол-во чисел: ');
readln(n);
repeat
 read(a);
 if ((a mod 2) = 1) then inc(k);
 inc(i);
 until i=n;
write(k);
end.

 n - кол-во чисел, k - кол-во нечётных чисел, a - число
Все числа вводятся через пробел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота