Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
wereweek777
21.11.2020 10:59 •
Информатика
Напишите программу(паскаль), которая считывает с клавиатуры вещественное число х и выдает на экран значение выражения 1\х. очевидно значение х=0 является недопустимым. для проверки вводимых с клавиатуры данных воспользуйтесь оператором repeat :
Показать ответ
Ответ:
232привет
05.07.2020 06:52
Var
x: real;
begin
readln(x);
if x=0 then exit;
write(1/x);
end.
Не понимаю, зачем тут repeat
0,0
(0 оценок)
Популярные вопросы: Информатика
NikaName007
14.05.2023 23:42
9чисел выбрасываются случайным образом из отрезка от - 2 до 10. подсчитать сумму чисел 2 и вывести на экран....
abbasbayaliev
11.08.2020 04:43
Запишите программу, в которой осуществляется: заполнение случайным образом целочисленного массива а, состоящего из 10 элементов, значения которых изменяются в диапазоне...
нина655
21.06.2022 01:44
1. для того чтобы вставить пустую страницу, нужно нажать комбинацию клавиш: 2. в ячейки b4, b5, c4, c5 введены соответственно числа: 10, 7, 6, 5. в ячейке с7 введена...
voolll
15.01.2023 18:24
Вычислите дробную часть среднего трех заданных вещественных чисел. программа в бейсике....
nasta086
02.03.2021 07:03
1. запишите значения элементов массива, сформированного следующим образом: for i: =1 to 7 do a[i]: =1;...
KatinaDobet2006
02.03.2021 07:03
Составить программу, которая запрашивает у пользователя два целых числа и выводит квадрат суммы (a+b)2и сумму квадратов a2+b2 ‘этих чисел. пример работы программы:...
LalkaDestroyer
02.03.2021 07:03
Ввести с клавиатуры 2 числа в интервале от 0 до 999. вывести их на экран столбиком в виде, удобном для сложения или умножения. то есть первый разряд первого числа...
UlianaIvleva
02.03.2021 07:03
Уисполнителя калькулятор, которым присвоены номера: 1) прибавить 1 2) умножить на 3 запишите порядок команд в программе получения из числа 1 число 45. содержащие...
alinika2007
03.05.2020 23:01
Даны записи выражения на языке Python, напишите их математическое выражение ...
Ventana1263
28.11.2020 10:28
4. Выполните трассировку программы. Результаты запишите в таблицу...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
x: real;
begin
readln(x);
if x=0 then exit;
write(1/x);
end.
Не понимаю, зачем тут repeat