В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
guliraj
guliraj
22.06.2022 05:39 •  Информатика

Напишите программу пересчета расстояния из километров в версты (1 верста равняется 1066,8 м).ниже представлен рекомендуемый вид экрана во время работы программы (данные,введённые пользователем,выделены курсивным шрифтом).

пересчет растояния из верст в километры.

введите расстояние в километрах --}100

100 км - это 93.73 версты

в pascal

Показать ответ
Ответ:
inzhu123345
inzhu123345
09.04.2021 00:40
Вот исходный код, даже прокомментировал: 

#include <iostream> //подключаем библиотеки 
#include <windows.h> //подключаем библиотеки 
#include <stdio.h> //подключаем библиотеки 
#include <conio.h> //подключаем библиотеки 
#include <string> //подключаем библиотеки 
using namespace std; //танцы с бубном 
int main() //танцы с бубном 2 

setlocale( LC_ALL,"Russian" ); //выводим все русскими буквами 
float s; //расстояние 
float r; //расход бензина 
float c; //цена бензина 
float k; //результат 
float b; //затраченный бензин 
float f; //удвоенное значение b 
float n; //объем бака 
float p; //проценты бака 
float g; //удвоить ли b 
float i; //скока баков потратите 
float z; //скока литров топлива потратите 

cout << "Программа для вычисления стоимости поездки куда-либо и обратно\n"; //пишем, что за прога 

cout << "Расстояние до места назначения (км) -> "; //просим ввести данные 
v:s; //ставим метку для возвращения 
cin >> s; //считываем значение 
if (s <= 0) //ставим условие если переменная меньше или равно 0, тогда пишем ошибку и возвращаемся 

cout << "Ошибка. Расстояние не может быть равно 0, введите еще раз -> "; 
goto v; 


cout << "Расход топлива (литров на 100 км пробега) -> "; //просим ввести данные 
x:r; //ставим метку для возвращения 
cin >> r; //считываем значение 
if (r <= 0) //ставим условие если переменная меньше или равно 0, тогда пишем ошибку и возвращаемся 

cout << "Ошибка. Расход топлива не может быть равно 0, введите еще раз -> "; 
goto x; 


cout << "Цена литра топлива (руб.) -> "; //просим ввести данные 
y:c; //ставим метку для возвращения 
cin >> c; //считываем значение 
if (c <= 0) //ставим условие если переменная меньше или равно 0, тогда пишем ошибку и возвращаемся 

cout << "Ошибка. Цена литра топлива не может быть равно 0, введите еще раз -> "; 
goto y; 


cout << "Введите объем бака (литров) -> "; //просим ввести данные 
h:n; //ставим метку для возвращения 
cin >> n; //считываем значение 
if (n <= 0) //ставим условие если переменная меньше или равно 0, тогда пишем ошибку и возвращаемся 

cout << "Ошибка. Объем бака не может быть равно 0, введите еще раз -> "; 
goto h; 


b = r / 100 * s; //рассчитываем значение переменной 
k = b * c; //рассчитываем значение переменной 
f = k * 2; //рассчитываем значение переменной 

cout << "Учитывать затраты на обратную дорогу? (1 да/0 нет) -> "; //просим ввести данные 
cin >> g; //считываем значение переменной 
if (g == 1) //ставим условие, если g = 1, тогда меняем расчета переменных 

f = k * 2; 
b = r / 100 * s; 

else 

f = k * 1; 
b = (r / 100 * s) / 2; 


z = n - b; //рассчитываем значение переменной 

cout << "\nПоездка до задуманного места обойдется в " << f << " руб.\n"; //выводим данные 

cout << "Вы потратите " << b << " литр. топлива\n"; //выводим данные 

cout << "У вас останется в баке " << z << " литр. топлива\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n"; //выводим данные

system("pause"); //в конце исполнения программы ждем нажатия любой кнопки и закрываемся) 
}
0,0(0 оценок)
Ответ:
89518099647
89518099647
09.02.2021 04:21
(сумма любых двух цифр числа всегда ≤ 18)

1414 - суммы цифр могут быть только 14 и 14 
148  -       только 14 и 8                                      
145  -        только 14 и 5                                     
                                
214    не может быть такого результата, так как суммы цифр  могут быть         только 2 и  14, но записаны они в порядке возрастания.
515  -  5 и 15 - записаны в порядке возрастания, не соответ. условию.
814 -   8 и 14 - не соотв. условию
114 -  11 и 4  (но может быть и 1 и 14) , в принципе - такой результат возможен
    ответ  5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота