В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
KrazyKot
KrazyKot
11.03.2023 13:40 •  Информатика

Напишите программу(phyton), которая находит сумму элементов массива и разность между максимальным и минимальным элементами. Массив задаётся случайными числами от - 20 до 50.

Показать ответ
Ответ:
romsik1999
romsik1999
12.01.2022 22:50

import random

a = list()

n = int(input())

for i in range(n):

   a.append(int(random.randint(-20, 50)))

print(*a)

print("sum = " + str(sum(a)))

print("max - min = " + str(max(a)) + " - " + str(min(a)) + " = " + str(max(a) - min(a)))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота