В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
zar26
zar26
25.06.2022 21:52 •  Информатика

Напишите программу покупателю подсчитать заранее общую
стоимость необходимых материалов (паркет и обои) для ремонта в квартире.
Стоимость материалов по умолчанию за 1 квадратный метр а также
сами значения площади пола и стен в доме пользователь будет вводить вручную.
Пример выполнения программы:
Введите цену за 1 кв.м паркета:
490
Введите цену за 1 кв.м обоев:
199
Какова площадь поверхности пола в доме?
50
Какова площадь поверхности стен в доме?
95
Стоимость паркета для ремонта: 24500
Стоимость обоев для ремонта: 18905
Общая стоимость покупки составит 43405 рублей

Показать ответ
Ответ:
Hhjkklknbggfddxxg
Hhjkklknbggfddxxg
21.09.2020 18:08

#include <iostream>

#include <windows.h>

 

using namespace std;

 

int main()

{

   int N;

   int* arr;

   cin>>N; //вводим размер массива

   arr = new int[N];

   for(int i=0;i<N;i++)  cin>>arr[i]; //вводим сам массив

   int NumOfFives = 0;

   for(int i=0;i<N;i++)

   {

     if(arr[i]==5) NumOfFives++;

   }

   cout<<NumOfFives<<endl; //выводим сколько пятёрок

   Sleep(5000); //ждём 5 секунд.

   delete arr;

   return 0;

}

 

/*

  P.S Так на будующее:  не алгоритм, а программу; C++ не программа, а язык; за такие задачи нужно побольше пунктов давать(мало кто знает C++(тут), а также задачи тут бывают полехче (куда уж легче? но бывают!) а пунктов ты даёшь минимум).

 

*/

0,0(0 оценок)
Ответ:
Кристинаголубь
Кристинаголубь
07.10.2020 15:36

Пишу задание вторым номером, поэтому постараюсь на качество.

Нам нужно найти сначала сумму всего роста, потом поделить его на общее количество учеников. Потом сопоставить каждый элемент со средним числом и высчитать количество высоких учеников.

Будет это выглядить так:

 

uses crt; //Если используете паскаль ABC, это строка нужна для удобства

Var a: array [1..25] of real; i,otvet: integer; h,s:real;

//Объявляем переменные. Массив,среднее число и суммарный рост - любые числа. Сам ответ - целые числа

Begin

  For i:=1 to 25 do begin
                      Writeln('Введите рост ученика номер  ',i); readln(a[i]); 

                           //Здесь мы вводим рост с клавиатуры
                    end;
  For i:=1 to 25 do
   s:=s+a[i];  

    //находим суммарный рост всех учеников
   h:=s/25;
   // делим на их количество. Теперь переменная h - это средний рост
 For i:=1 to 25 do
  if a[i]>h then otvet:=otvet+1;
  // А здесь проверяем каждый элемет массива. Если он выше значения среднего роста, мы прибавляем единицу к переменной "otvet". Там мы считаем количество высоких уч.
  Writeln('Средний рост в классе равен ',h);
 Writeln('Количество высоких учеников в классе равно  ',otvet);

//вывод данных
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота