Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Ник6911
22.11.2022 16:31 •
Информатика
Напишите программу, при которой можно подсчитать расходы на доставку мебели. исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). c++
Показать ответ
Ответ:
ЕлизаветаАлис
08.10.2020 21:37
Надеюсь без ошибок. Цену за отдельные аспекты назначте сами:
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
vlada410
04.01.2022 10:50
Сумма вводимых чисел. паскаль abc. 8 класс...
maloypipos
28.02.2022 04:48
Обсудите, можно ли сохранить фотографию в векторном формате...
ЮлічкаВдовіна
03.04.2020 22:49
Всберегательный банк метеор в начале года положена сумма х.р.на вклад ежегодно начисляется 64,9%( капитализированный процент).подберите начальную сумму вкладу так,чтобы после девяти...
Dianapro111
21.04.2022 08:11
Склавиатуры вводится число n под корнем. если это число больше нуля, то найти его квадратные корни. если число отрицательное, то возвести его в квадрат...
milla25
23.12.2022 00:17
Какие направления и азимут у следующих объектов? 1-Рыжово2-лес.береза,осина3-Одинцово4-воробьи5-школа6-лес.дуб,ясень...
Вппгш
01.03.2023 14:42
Сторону квадрата увеличили в 7 раз и получили новый квадрат, площадь которого на 192 см2 больше площади данного квадрата. Найди сторону данного квадрата....
qpdgjekelxnvi
08.06.2022 19:20
5. Трикутник NMK (ZM= 90°) — прямо- кутний. З точки А, яка належить катету MN, проведено перпендикуляр АВ до гі- потенузи. Знайти довжину відрізка NB, якщо МN= 12 см, MK = 8 см, AB...
Катрин1907
15.04.2022 00:25
15 бет, 5- тапсырма. Мәтін бойынша сұрақтар құрастырып, диалог құрыңдар. По тексту состовьте диалог. - Мәтінде қандай мақал бар? Оны қалай түсіңдің? -Әңгіме авторы саған таныс па?...
yuliya91
28.01.2022 12:55
Опишить яким у народний уяви постайе Максим Залізняк...
Bakeneko77
28.01.2022 12:55
Ни огня, ни чёрнрй хаты. Какая грамматическая основа ....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include stdlib.h
#include <iostream>
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor <= 6 && floor > 3) price_floor=2;
if (floor <= 9 && floor > 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <<endl;
system ("pause");
return 0;
}