В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, и выводится сумма цифр этого числа.
Язык программирования — Python

Показать ответ
Ответ:
Nemo24
Nemo24
04.11.2021 17:20

Программа:

Python:

Вариант 1)

N = int(input())

sum = 0

while N > 0:

   j = N % 10

   N //= 10

   sum += j

print(sum)

Вариант 2)

print(sum([int(j) for j in input()]))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота