В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
кузя216
кузя216
14.07.2020 03:34 •  Информатика

Напишите программу, реализующую игру на угадывание целого числа от 1 до 10. угадываемое число определяется случайно, пользователь вводит предполагаемое значение. если число угадано, программа выводит набранные очки, а если нет-предлагает повторить попытку. каждая безуспешная попытка снижает . в начале игры назначается 10 . , , составить сдать надо завтра.

Показать ответ
Ответ:
bonchuk2009
bonchuk2009
27.08.2020 06:23
Var a,b,k,i:integer;
begin
b:=random(10)+1;
k:=10;
WriteLn('Привет, я задумал число от 1 до 10. Угадай его.');
while a<>b do
begin
Write('Введи число: ');
ReadLn(a);
if a<>b then
begin
WriteLn('Не угадал... Попробуй повторить попытку.');
k:=k-1
end
end;
WriteLn('Молодец! Угадал! Набранные очки: ',k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота