Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
khludenev99
18.01.2020 10:23 •
Информатика
Напишите программу реализующую калькулятор на 4 арифметических действия.на языке паскаль
Показать ответ
Ответ:
Dianapro111
10.09.2020 12:17
Program test;
var
a,b:integer;
rezultat:real;
sign:char;
begin
rezultat:=0;
writeln('Введите числа a, b: ');
readln(a, b);
writeln('Введите знак операции: ');
readln(sign);
case sign of
'+': rezultat:=a+b;
'-': rezultat:=a-b;
'*': rezultat:=a*b;
'/': rezultat:=a/b else writeln('An error occurred: Invalid operation! Try again!');
end;
writeln(rezultat);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
avernius
08.09.2022 18:15
Укажите 3 D редакторы для моделирования? SketchUpAutocadC++ArchiCad17BorlandDeiphi...
dollfasse
27.05.2021 13:19
Для хранения растрового изображения размером 64 из 64 пикселя отвели 1024 Kбайт памяти. Какое максимальное возможное число цветов в палитре изображения?...
МировойПельмень
20.05.2022 12:25
Что такое информатика? Что такое информация?Что такое система счисления?Что такое бит, байт?...
Han121
14.02.2022 11:37
Написать программу на языке программирования ...
rusnaktaniusha
01.04.2023 01:09
1. найти произведение положительных элементов массива x(9). 2. заменить элементы, значения которых равны числу 4, числом -4. данные задать самостоятельно в массиве...
karinaklinaeva
27.07.2021 18:51
Файл размером 2 кбайта передаётся через некоторое соединение со скоростью 256 бит в секунду. определите размер файла (в байтах), который можно передать за то же...
kirichmix
17.01.2022 10:33
Какие чуства были рикки -тикки и нага при их встрече...
PYULIK12
12.01.2021 00:08
10 класс в корзине лежат 6 красных и 10 желтых кубиков. какое количество информации несут сообщения о том, что достали красный? ? воспользуйтесь формулами: (p=k/n)...
matuezh
30.07.2021 20:18
Для узла с ip-адресом 63.132.140.28 адрес сети равен 63.132.140.0. найдите наибольшее возможное количество единиц в двоичной записи маски подсети....
18000000
11.10.2020 04:33
Типоловнішим знаряддям боротьби із життєвими для олібуло: а) уміння задобрювати богів, везіння; б) гнучкий розум та сила духу; в) активна підтримка з боку всіх...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
a,b:integer;
rezultat:real;
sign:char;
begin
rezultat:=0;
writeln('Введите числа a, b: ');
readln(a, b);
writeln('Введите знак операции: ');
readln(sign);
case sign of
'+': rezultat:=a+b;
'-': rezultat:=a-b;
'*': rezultat:=a*b;
'/': rezultat:=a/b else writeln('An error occurred: Invalid operation! Try again!');
end;
writeln(rezultat);
end.