9.Определите значение переменной a после выполнения фрагмента программы:
a:=10;
b:=3;
if a > b then b:=b+12//а больше б, значит к б прибавим 12 и получим что б 21
else a:=a-7;//а это игнорим
if a > b then a:=a+12//теперь а не больше б(б21 а а 10), так что к а прибавим 12, получаем а 22
else a:=a-7;// а это игнорим
А = 22.
11.Определите что будет напечатано в результате работы следующей программы.
Var k,i: integer;
Begin
k :=4;/к равно 4
For i := 1 to 3 do//следующая строка повториться 3 раза, а и при этом будет меняться от 1 до 3
k := 2*k +i;
// При и равном 1 к станет 9
// При и равном 2 к станет 20
// При и равном 3 к станет 43
Writeln(k);// выведет 43
end.
ответ 43
12.Определите что будет напечатано в результате работы следующей программы.
Var s,i: integer;
s :=3;
For i := 2 to 5 do// и будет меняться от 2 до 5
s := s+2*i
//К с будет прибавляется 2i т.е. сперва 3;7;13;21;31
Writeln(s) ;//31
end
ответ:31
13.Определите что будет напечатано в результате работы следующей программы.
Var s,n: integer;
s :=1;
For n := 3 to 8 do//повториться 6 раз
s := s*2// каждый раз s увеличивается вдвое, т.е.это 2 в 6 степени
write(s) ;
ответ:64
14.Чему будет равно значение переменной а после выполнения этого цикла?
i:=4;
a:=12;
while i<6 do begin//по сути он повторится 2 раза, а и будет принимать значение от 4 до 5
a:=a+i;//а увеличиваем на и: сперва это 16, потом 21
i:=i+1
ответ:21
70, 35, 43, 132, 121, 11, 60, 64, 24, 31
Объяснение:
1) Изначально s = 0, затем на каждой из 12 – 6 + 1 = 7 итераций к ней прибавляется 10, итого получится 70
2) Аналогично, s = 0 + 7 * (8 – 3) = 35
3) Итерация с i = 1: k = 2 * 4 + 1 = 9. Итерация с i = 2: k = 2 * 9 + 2 = 20. Итерация с i = 3: k = 2 * 20 + 3 = 43.
4) s = 0 + 12 * 11 = 132
5) s = 0 + 11 * (12 – 1) = 121
6) u = 26 – 1 – 2 – 3 – 4 – 5 = 11
7) s = 4 + 5 + … + 11 = 60
8) s = 1 * 2 * 2 * … * 2 (8 – 3 + 1 раз) = 64
9) y = 0 + 4 * 1 + 4 * 2 + 4 * 3 = 24
10) s = 3 + 2 * 2 + 2 * 3 + 2 * 4 + 2 * 5 = 31
9.Определите значение переменной a после выполнения фрагмента программы:
a:=10;
b:=3;
if a > b then b:=b+12//а больше б, значит к б прибавим 12 и получим что б 21
else a:=a-7;//а это игнорим
if a > b then a:=a+12//теперь а не больше б(б21 а а 10), так что к а прибавим 12, получаем а 22
else a:=a-7;// а это игнорим
А = 22.
11.Определите что будет напечатано в результате работы следующей программы.
Var k,i: integer;
Begin
k :=4;/к равно 4
For i := 1 to 3 do//следующая строка повториться 3 раза, а и при этом будет меняться от 1 до 3
k := 2*k +i;
// При и равном 1 к станет 9
// При и равном 2 к станет 20
// При и равном 3 к станет 43
Writeln(k);// выведет 43
end.
ответ 43
12.Определите что будет напечатано в результате работы следующей программы.
Var s,i: integer;
Begin
s :=3;
For i := 2 to 5 do// и будет меняться от 2 до 5
s := s+2*i
//К с будет прибавляется 2i т.е. сперва 3;7;13;21;31
Writeln(s) ;//31
end
ответ:31
13.Определите что будет напечатано в результате работы следующей программы.
Var s,n: integer;
Begin
s :=1;
For n := 3 to 8 do//повториться 6 раз
s := s*2// каждый раз s увеличивается вдвое, т.е.это 2 в 6 степени
write(s) ;
end.
ответ:64
14.Чему будет равно значение переменной а после выполнения этого цикла?
i:=4;
a:=12;
while i<6 do begin//по сути он повторится 2 раза, а и будет принимать значение от 4 до 5
a:=a+i;//а увеличиваем на и: сперва это 16, потом 21
i:=i+1
end.
ответ:21
70, 35, 43, 132, 121, 11, 60, 64, 24, 31
Объяснение:
1) Изначально s = 0, затем на каждой из 12 – 6 + 1 = 7 итераций к ней прибавляется 10, итого получится 70
2) Аналогично, s = 0 + 7 * (8 – 3) = 35
3) Итерация с i = 1: k = 2 * 4 + 1 = 9. Итерация с i = 2: k = 2 * 9 + 2 = 20. Итерация с i = 3: k = 2 * 20 + 3 = 43.
4) s = 0 + 12 * 11 = 132
5) s = 0 + 11 * (12 – 1) = 121
6) u = 26 – 1 – 2 – 3 – 4 – 5 = 11
7) s = 4 + 5 + … + 11 = 60
8) s = 1 * 2 * 2 * … * 2 (8 – 3 + 1 раз) = 64
9) y = 0 + 4 * 1 + 4 * 2 + 4 * 3 = 24
10) s = 3 + 2 * 2 + 2 * 3 + 2 * 4 + 2 * 5 = 31