Напишите программу с интерфейсом visual basic Функцию выделяющую первую подстроку из строки по начальному и конечному символу. Проверить, не выходит ли конечный символ за пределы строки.
Const n=20; var a:array[1..n] of integer; i,i1,i2,x:integer; begin Randomize; a[1]:=random(10); write(a[1],' '); for i:=2 to n do begin a[i]:=a[i-1]+random(10); write(a[i],' '); end; writeln; write('x = '); readln(x); i1:=1; i2:=n; repeat i:=(i1+i2) div 2; if a[i]<x then i1:=(i1+i2) div 2+1; if a[i]>x then i2:=(i1+i2) div 2-1; until (a[i]=x)or(i1>i2); if a[i]=x then begin writeln('Искомый(ые) номер(а) элемента(ов):'); while (i>0)and(a[i]=x) do i:=i-1; i:=i+1; while (i<=n)and(a[i]=x) do begin write(i,' '); i:=i+1; end; end else writeln('Элемент не найден'); writeln; end.
номер 1-интернет - всемирная паутина, которая хранит в себе тонны информации. он заменяет нам любой источник информации и облегчает понимание.
газеты/журналы - письменные, или же стандартные способы получения информации на бумаге.
телевидение - самый удобный источник информации. содержит в себе и картинку, и звук, и приятную визуализацию.
постеры/афиши - бумажки расклеенные по городу или же огромные постеры размещенные на зданиях. привлекает внимание, тем самым увеличивает число интересующихся.
радио - звуковая информация, уже перестает быть актуальной. в основном, радио - это не новости, а что-то более развлекательное.
номер 2-к примеру, кто-то описывает картину на бумаге (повествованием), тем самым переводит графическую информацию в текстовую. рассказывает вслух - уже в звуковую. и т. д.
номер 3-написание дипломного проекта из своего же курсового, время прошло законы изменились и теперь за одни и теже административные проступки другие наказания, но дабы не писать с нуля все это лучше обработать свой же курсовик соответственно изменив его содержание
var a:array[1..n] of integer;
i,i1,i2,x:integer;
begin
Randomize;
a[1]:=random(10);
write(a[1],' ');
for i:=2 to n do
begin
a[i]:=a[i-1]+random(10);
write(a[i],' ');
end;
writeln;
write('x = '); readln(x);
i1:=1; i2:=n;
repeat
i:=(i1+i2) div 2;
if a[i]<x then i1:=(i1+i2) div 2+1;
if a[i]>x then i2:=(i1+i2) div 2-1;
until (a[i]=x)or(i1>i2);
if a[i]=x then
begin
writeln('Искомый(ые) номер(а) элемента(ов):');
while (i>0)and(a[i]=x) do i:=i-1;
i:=i+1;
while (i<=n)and(a[i]=x) do begin write(i,' '); i:=i+1; end;
end
else writeln('Элемент не найден');
writeln;
end.
Пример:
5 6 14 15 15 22 30 36 45 45 50 56 60 64 67 76 84 92 99 101
x = 15
Искомый(ые) номер(а) элемента(ов):
4 5
ответ:
номер 1-интернет - всемирная паутина, которая хранит в себе тонны информации. он заменяет нам любой источник информации и облегчает понимание.
газеты/журналы - письменные, или же стандартные способы получения информации на бумаге.
телевидение - самый удобный источник информации. содержит в себе и картинку, и звук, и приятную визуализацию.
постеры/афиши - бумажки расклеенные по городу или же огромные постеры размещенные на зданиях. привлекает внимание, тем самым увеличивает число интересующихся.
радио - звуковая информация, уже перестает быть актуальной. в основном, радио - это не новости, а что-то более развлекательное.
номер 2-к примеру, кто-то описывает картину на бумаге (повествованием), тем самым переводит графическую информацию в текстовую. рассказывает вслух - уже в звуковую. и т. д.
номер 3-написание дипломного проекта из своего же курсового, время прошло законы изменились и теперь за одни и теже административные проступки другие наказания, но дабы не писать с нуля все это лучше обработать свой же курсовик соответственно изменив его содержание
номер 4-молекула днк
оптические носители
египитские папирусы
бумага