Напишите программу с использованием функции которая определяет, в каком из двух массивов количество положительных элементов больше. Все необходимые параметры и их значения задайте самостоятельно. Создайте 3 варианта программы с различными передачи массива в функцию С++
a:array[1..18] of integer;
i,n,n2,max:integer;
Begin for i:=1 to 18 do Begin
case i of
1..6:begin Write('Введите ',i,'-ую оценку по обязательной программе '); Readln(a[i]); n:=n+a[i]; if i=6 then Begin max:=n; n:=0; n2:=1; End; End;
7..12:Begin Write('Введите ',i-6,'-ую оценку по короткой программе '); Readln(a[i]); n:=n+a[i]; if i=12 then Begin if n>max then Begin max:=n; n2:=2;End; n:=0; End; End;
13..18:Begin Write('Введите ',i-12,'-ую оценку по произвольной программе '); Readln(a[i]); n:=n+a[i]; if i=18 then Begin if n>max then Begin max:=n; n2:=3;End; n:=0; End; End;
end;
end;
case n2 of
1: write('Лучшая оценка по обязательной программе = ',max);
2: write('Лучшая оценка по короткой программе = ',max);
3: write('Лучшая оценка по произвольной программе = ',max);
End;
End.
2) здесь скорее всего имелось ввиду, что все пойдут в лес. И это верно. Если Света пойдет в лес, то все возьмут корзины и ножики и все пойдут в лес, потому что в лес идет Миша, с ним Настя. Уже идут и Света и Настя в лес, с ними тогда Маша. Света и Настя не идут на рыбалку, значит с ними Гриша, а с Гришей и Алексей. Все пойдут в лес!
3) неверно, т.к. если Миша идет на рыбалку, то с ним Настя.
4) неверно, т.к. Миша хочет в лес независимо от решения Светы, а вместе с Мишей пойдет и Настя, их уже двое