В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kategys
kategys
24.11.2022 01:21 •  Информатика

Напишите программу с использованием условного оператора Столицы России, Испании и Монголии - Москва, Мадрид и Улан-Батор соответственно. Напишите программу, которая выводит столицу страны по введённому названию государства. Учтите ввод страны, которая не приведена в списке. программа Паскаль

Показать ответ
Ответ:
WhiteBurn
WhiteBurn
23.05.2023 13:55
16777216=2^24, поэтому для кодирования цвета одного пикселя необходимо отвести 24 бита = 3 байта (в одном байте 8 бит).

В экране 1024 * 768 пикселей, на 1 пиксель отводится 3 байта, значит, на один кадр приходится 1024 * 768 * 3 байт = 768 * 3 Кбайт = 0,75 * 3 Мбайт = 2,25 Мбайт (в одном Кбайте 1024 байта, в одном Мбайте 1024 Кбайта)

Частота смена кадра означает, сколько раз в секунду сменяется кадр. В данном случае в секунду кадр сменяется 76 раз, объём переданной за секунду информации 76 * 2,25 Мбайт = 171 Мбайт

Ответ: 171 Мбайт.
0,0(0 оценок)
Ответ:
Yana18102001
Yana18102001
27.01.2023 19:48
#include "stdafx.h"
#include <stdio.h>
#include <windows.h>

int main()  
  {
    SetConsoleCP(1251);      
    SetConsoleOutputCP(1251);  
 
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;

for (int i=0; i<n; i++)
    for (int j=0; j<n; j++)
         {
           printf("mas[%d][%d] = ", i+1, j+1);
           scanf("%d",&mas[ i ][ j ]);
         }

printf("\nВведенная матрица:\n");
     for (int i=0; i<n; i++)
        {
             for (int j=0; j<n; j++)
                       {
                          printf("%d  ",mas[ i ][ j ]);
                       }
             printf("\n");
         }

sum1=0;
sum2=0;

for (int i = 0; i<n; i++)
     {
            sum1 += mas[ i ][ i ];
            sum2 += mas[ i ][ n-1-i ];
      }

printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);

magik = true;
for (int i=0; i<n; i++)
    {
        if (sum1==sum2)
             {
                 sum2=0;
                 for (int j=0; j<n; j++)
                    {
                        sum2 += mas[ i ][ j ];
                     }
              } else  { magik=false; break; }
     }

if (magik==true)
     {
           for (int i=0; i<n; i++)    
               {
                   if (sum1==sum2)
                        {
                           sum2=0;
                           for (int j=0; j<n; j++)
                               {
                                   sum2 += mas[ j ][ i ];
                               }
                         }
                        else  { magik=false; break; }
                 }
       }

if (magik==true)
    printf("\nМатрица является магическим квадратом\n");  
else
    printf("\nМатрица не является магическим квадратом\n");

system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота