В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
anechka1234567892
anechka1234567892
28.06.2022 21:26 •  Информатика

Напишите программу с клавиатуры вводится n целых чисел, nтоже вводится с клавиатуры. найти сумму нечетных, оканчивающихся на 7 или сообщить, что таких чисел в введенной последовательности нет

Показать ответ
Ответ:
женьшенье
женьшенье
06.10.2020 00:02
Var n,i,a,s,f:integer;
begin
write('n = ');
readln(n);
s:=0; f:=0;
for i:=1 to n do
 begin
 readln(a);
 if abs(a) mod 10 = 7
  then begin s:=s+a; f:=1; end;
 end;
if f=1
 then writeln('Сумма нечетных чисел, оканчивающихся на 7 = ',s)
 else writeln('среди введенных чисел нет нечетных, оканчивающихся на 7');
end.

Пример:
n = 5
25
-17
71
68
27
Сумма нечетных чисел, оканчивающихся на 7 = 10
0,0(0 оценок)
Ответ:
olgagolova2007
olgagolova2007
06.10.2020 00:02
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger(ReadInteger).Where(m->abs(m) mod 10=7).ToArray;
  if a.Length=0 then Writeln('Нет чисел, оканчивающихся на 7')
  else Writeln('Сумма чисел, оканчивающихся на 7: ',a.Sum)
end.

Пример
5
16 37 3 7 -27
Сумма чисел, оканчивающихся на 7: 17
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота