В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ruslansuxenco3
ruslansuxenco3
23.05.2022 23:18 •  Информатика

Напишите программу создания n-символьной последовательности, состоящей из совокупности 3 символов с использованием строк (например '0', '1', '2' или 'a', 'b', 'c') в которой нет двух смежных идентичных подпоследовательностей. для n=11 последовательность может иметь вид "01020120210".

Показать ответ
Ответ:
TurboDan
TurboDan
03.10.2020 03:34
#include <iostream>
#include <string>
#include <time.h>
using namespace std;

void main()
 {
srand(time(NULL));
int n,k=0,k1=4;
cin >> n;                         //вводишь количество символов
string *s=new string [n];
for (int i = 0;i < n;++i)
{
while (k == k1)
{
k = rand() % 3;
}
switch (k)
{
case 0:s[i] = '0';cout << s[i];break;
case 1:s[i] ='1';cout << s[i];break;    //вместо 0,1,2 пишешь свой алфавит .
case 2:s[i] ='2';cout << s[i];break;
}
k1 = k;
}
system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота