В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу ТОЛЬКО В КУМИРЕ (нц для), которая в последовательности натуральных чисел определяет сумму чисел, кратных 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму чисел, кратных 5. Очень надо

Показать ответ
Ответ:
stentani97
stentani97
04.04.2021 14:24

const m=10; n=12;
var a:array [1..m,1..n] of integer;
i,j:integer;
sob:integer;
sst:array[1..n]of integer;
sstr:array[1..m]of integer;
begin
randomize;
for i:=1 to m do begin
for j:=1 to n do begin
a[i,j]:=random(10);
write(a[i,j]:3);
end;
writeln;
end;
sob:=0;
for i:=1 to m do begin
for j:=1 to n do begin
sob:=sob+a[i,j];
end;
end;
writeln('сумма всех элементов массива = ', sob);
writeln;
writeln;
for i:=1 to m do begin
sstr[i]:=0;
for j:=1 to n do begin
sstr[i]:=sstr[i]+a[i,j];
end;
end;
writeln('сумма элементов построчно');
for i:=1 to m do write(sstr[i]:3);
writeln;
writeln;
for j:=1 to n do begin
sst[j]:=0;
for i:=1 to m do begin
sst[j]:=sst[j]+a[i,j];
end;
end;
writeln('сумма элементов по столбцам');
for j:=1 to n do write(sst[j]:3);
end.

0,0(0 оценок)
Ответ:
worldteawithlemon
worldteawithlemon
13.09.2020 13:54
1.
Числа можно вводить
int k,l; cout<<"->"; cin>>k>>l; if (k==l) { k=0; l=0; cout<<k<<" "<<l<<endl; }  else   {  l=k;  cout<<k<<" "<<l<<endl;  }
если хочешь без ввода удали cin и присвой значения

2.
int k,l,z; cout<<"->"; cin>>k>>l>>z;  if (k>0)  {  k*=k;  cout<<k<<endl;  }   if (l>0)  {  l*=l;  cout<<l<<endl;  }   if (z>0)  {  z*=z;  cout<<z<<endl;  }   if (k<0)  {  cout<<k<<endl;  }   if (l<0)  {  cout<<l<<endl;  }   if (z<0)  {    cout<<z<<endl;  }  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота