В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Military47
Military47
18.12.2020 18:46 •  Информатика

Напишите программу.Требуется ввести 4 числа (положительных и отрицательных) определить среди них максимальное.(Это через Паскаль

Показать ответ
Ответ:
Chicken10
Chicken10
23.02.2022 08:05

Псевдокод :

Начало

объявление целых переменных a и b

ввод a,b

вывод a+b

вывод a*b

Конец

c# :

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;

namespace _1

{

   class Program

   {

       static void Main(string[] args)

       {

           Console.Write("Число a : ");

           int a = int.Parse(Console.ReadLine());

           Console.Write("Число b : ");

           int b = int.Parse(Console.ReadLine());

           Console.WriteLine("Сумма чисел a и b : {0}",a+b);

           Console.WriteLine("Произведение чисел a и b : {0}", a*b);

           Console.ReadKey();

       }

   }

}

PascalABC :

var

 a,b:integer;

Begin

 readln(a,b);

 writeln(a+b);

 writeln(a*b);

End.

0,0(0 оценок)
Ответ:
Legendplay228
Legendplay228
23.02.2022 08:05
Допустим число 123. Нам нужно найти первое, второе и третье его число.
То есть 1,2,3. потом их сложить или перемножить.
Чтобы найти первое число нужно 123 разделить на 100,получиться 1.23,его мы округляем и получаем 1.
Второе мы находим деля 123 на 100,получаем остаток 23, делим остаток на 10 и получаем 2.
Третье число мы находим деля 123 на 10 и получаем остаток.
Потом складываем их или перемножаем.
Пример на  pascal:
//div это делить,mod отстаток
var a,b,c,s: integer;
begin
Write('Введи число: ');
Read(s);
a:= s div 100;
b:= s mod 100 div 10;
c:= s mod 10;
WriteLn('Сумма: '+a+b+c);
WriteLn('Произведение: '+a*b*c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота