В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LusiyLusiy
LusiyLusiy
26.02.2020 02:22 •  Информатика

Напишите программу, удаляющую из слова i-ю букву. в алгоритмическом языке и блок схему.

Показать ответ
Ответ:
catdog12
catdog12
23.07.2020 16:59
Вариант с процедурой Delete

var
  s:string;
  k:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  Delete(s,k,1);
  Writeln('Результат: ',s)
end.

Вариант с функцией Copy

var
  s:string;
  k,n:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  n:=Length(s);
  s:=Copy(s,1,k-1)+Copy(s,k+1,n-k);
  Writeln('Результат: ',s)
end.

Вариант с циклами

var
  s,s1:string;
  k,i,n:integer;
begin
  Write('Введите слово: '); Readln(s);
  Write('Какую по порядку букву удалить? '); Read(k);
  n:=Length(s);
  s1:='';
  for i:=1 to k-1 do s1:=s1+s[i];
  for i:=k+1 to n do s1:=s1+s[i];
  Writeln('Результат: ',s1)
end.

Тестовое решение (одинаково для всех вариантов):
Введите слово: Таракан
Какую по порядку букву удалить? 4
Результат: Таркан

Блок-схемы всех вариантов находятся во вложениях
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота