В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу в basic256, чтобы компьютер спрашивал "ты любишь мороженое? ". если да, то компьютер отвечает "я тоже! ", а если нет — "поделись с другом".

Показать ответ
Ответ:
Даниад
Даниад
24.02.2023 08:39

оператор присваивания :=

оператор ввода read(x1,x2,...,xn) или readln(x1,x2,...,xn)

оператор вывода write(x1,x2,...,xn) или writeln(x1,x2,...,xn)

условный оператор if условие then оператор 1 else оператор 2

оператор варианта case управляющая переменная of

                                     набор значений1: оператор1;

                                     набор значений2: оператор2;

                                     ...

                                     набор значенийn: операторN

                               else

                                    альтернативный оператор

                              end;

оператор цикла с предусловиями while ... do

оператор цикла с постусловием repeat ... until

оператор цикла for ... do

оператор break осуществляет немедленный выход из циклов repeat, while, for.

оператор continue начинает новую итерацию цикла, даже если предыдущая не была завершина.

оператор exit осуществляет выход из подпрограммы.

оператор halt прекращает выполнение программы и возвращает код завершения в операционную систему.

0,0(0 оценок)
Ответ:
Gulya55555
Gulya55555
25.05.2022 10:05

Объяснение:

procedure F(n: integer);

begin

 if n>0 then begin

   Write (n);

   F(n-2);

   F(n div 4);

   end

end;

begin

 F(9);

end.

На выходе будет 97531112

Если нужна трассировка, её можно сделать примерно так:

procedure F(n: integer);

begin

 Writeln('Вход');

 if n>0 then begin

   Writeln ('В выходную строку: ',n);

   Writeln('Вызов F(n-2)');

   F(n-2);

   Writeln('Вызов F(n div 4)');

   F(n div 4);

   end;

   Writeln('Выход')

end;

begin

 F(9);

end.

Результат трассировки:

Вход

В выходную строку: 9

Вызов F(n-2)

Вход

В выходную строку: 7

Вызов F(n-2)

Вход

В выходную строку: 5

Вызов F(n-2)

Вход

В выходную строку: 3

Вызов F(n-2)

Вход

В выходную строку: 1

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Вызов F(n div 4)

Вход

В выходную строку: 1

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Выход

Вызов F(n div 4)

Вход

В выходную строку: 1

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Выход

Вызов F(n div 4)

Вход

В выходную строку: 2

Вызов F(n-2)

Вход

Выход

Вызов F(n div 4)

Вход

Выход

Выход

Выход

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота