В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
tupykomiks
tupykomiks
03.01.2023 01:40 •  Информатика

Напишите программу в C++ которая в последовательности натуральных чисел вычисляет сумму трёхзначных чисел оканчивающихся на 5. Программа получает на вход натуральные числа, количество чисел неизвестно, последовательность чисел заканчивается числом 0

Показать ответ
Ответ:
jenek28022008
jenek28022008
14.08.2021 01:28

Объяснение:

Анализ содержаний следовых количеств тяжелых металлов традиционными физико-химическими методами (атомная абсорбция, полярография, фотометрия и др.) требует предварительной пробоподготовки, т.к. металлы в большинстве объектов находятся в связанном состоянии. Они образуют достаточно прочные органические комплексы, мешающие точному и воспроизводимому определению их содержания. Поэтому перед любым анализом необходимо предварительно разрушить органическую составляющую пробы.

При подготовке проб к анализу методами ААС, ИСП-МС и ИСП-АЭС наибольшее развитие получило мокрое озоление проб различными кислотами при СВЧ-поля под давлением (СВЧ-минерализации под давлением).

Процесс минерализации проходит следующим образом: разлагаемая проба и окислительные реагенты помещаются в специальный сосуд из радиопрозрачного химически инертного материала (стекло, кварц, фторопласт), сосуд при необходимости герметично закрывается, переносится в микроволновую систему и реакционная смесь нагревается в СВЧ поле. При этом суммарное время пробоподготовки сокращается в десятки и сотни раз.

0,0(0 оценок)
Ответ:
kjgftgv
kjgftgv
26.09.2022 01:13
Var
  a : array [1..5, 1..5] of integer;
  i, j : integer;
begin
  randomize;
  for i := 1 to 5 do
  begin
    for j := 1 to 5 do
    begin
      a[i, j] := random (1000);
      write (a[i, j], ' ');
    end;
    writeln;
  end;
  for i := 1 to 5 do
    for j := 1 to 5 do
      if i > j then a[i, j] := 1
      else if j > i then a[i, j] := 0;
  for i := 1 to 5 do
  begin
    for j := 1 to 5 do
      write (a[i, j], ' ');
    writeln;
  end;
end.

var
  a : array [1..4, 1..5] of integer;
  i, j, m, c : integer;
begin
  randomize;
  m := 1000;
  for i := 1 to 4 do
  begin
    for j := 1 to 5 do
    begin
      a[i, j] := random (1000);
      if a[i, j] < m then m := a[i, j];
      write (a[i, j], ' ');
    end;
    writeln;
  end;  
  c := 0;
  for i := 1 to 4 do
    for j := 1 to 5 do  
      if a[i, j] = m then
        c := c + 1;
  writeln (m, ' ', c);
end.

var
  a : array [1..4, 1..4] of integer;
  i, j, p : integer;
begin
  randomize;
  for i := 1 to 4 do
  begin
    for j := 1 to 4 do
    begin
      a[i, j] := random (10);
      write (a[i, j], ' ');
    end;
    writeln;
  end;
  p := 1;
  for i := 1 to 4 do
  begin
    if a[i, i] <> 0 then p := p * a[i, i];
    if a[i, 5 - i] <> 0 then p := p * a[i, 5 - i];
  end;
  writeln (p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота