Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
degorov152
02.05.2023 02:30 •
Информатика
Напишите программу в дельфи которая переводит число из десятичной в факториальную систему счисления.
Показать ответ
Ответ:
pashasergo
06.10.2020 02:09
Консольное приложение:
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
begin
i:=i+1;
str(k mod i,m);
f:=m+f;
k:= k div i;
end;
writeln('f = ',f);
end.
Пример:
n = 100
f = 4020
0,0
(0 оценок)
Популярные вопросы: Информатика
MyrkaPC325
13.06.2022 18:29
Примеры (5 штук) передачи информации в неживой и живой природе...
kmtva04
21.02.2023 15:53
3. в квартире 4 шкафа, в каждом шкафу по 32 полки. какое количество информации содержится в сообщении, что книга лежит на 5 полке в третьем шкафу....
полина18501
24.11.2022 02:24
Сномер 7 на странице 32 учебник по информатике 9 класс семакин зологова 2013 года...
ar2018borisov
17.02.2021 06:27
23 . информатика 1. переведите число 34е16 в десятичную систему счисления х10. 2. переведите ответ 1 (десятичное число х10 ) в двоичную систему счисления х2. 3. ответ 2...
bkmz987
22.03.2021 02:57
Найдите в таблице слова и термины по теме...
дима55922
26.02.2022 23:56
Встречено else , а ожидался оператор(в чём ошибка) var a: integer; begin writeln ( введите число ); readln(a); if a mod 2=0 then writeln( число чётное ); else writeln(...
BooWim
26.02.2022 23:56
Почему бумага стала самым популярным твёрдым носителем информации?...
tsaturyansyuza
26.02.2022 23:56
Запиши число 14471 в развёрнутом виде, начиная со старшего разряда...
shaplen
15.11.2022 12:24
Подготовьте небольшое сообщение об одной из систем счисления (когда и где применялась, какие символы использовались и так далее)....
hromovaysoydwfz
17.05.2020 23:20
Заполните схемы (характеристики ОС и их определение)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var n,k,i:integer; m,f:string;
begin
write('n = ');
readln(n);
k:=n;
f:='';
i:=1;
while k>0 do
begin
i:=i+1;
str(k mod i,m);
f:=m+f;
k:= k div i;
end;
writeln('f = ',f);
end.
Пример:
n = 100
f = 4020