В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Неко6тян
Неко6тян
11.04.2021 00:06 •  Информатика

Напишите программу:
В каждой строке файла записано три числа,
каждое из которых находится в интервале
[0,255]. Эти числа обозначают красную,
зелёную и синюю составляющие цвета в
цветовой модели RGB. Запишите в другой
файл полные коды заданных цветов в виде
целых чисел (код цвета = 255·255·R + 255·G
+ B).

Показать ответ
Ответ:
maksi71
maksi71
11.05.2021 14:01

#include <iostream>

using namespace std;

bool is_point_in_circle(double x, double y, double xc, double yc, double r);

int main()

{

double x, y, xc, yc, r;

bool result;

cin >> x >> y >> xc >> yc >> r;

result = is_point_in_circle(x, y, xc, yc, r);

if (result) cout << "YES";

else cout << "NO";

return 0;

}

bool is_point_in_circle(double x, double y, double xc, double yc, double r)

{

if ((x - xc) * (x - xc) + (y - yc) * (y - yc) < r * r) return true;

return false;

}

0,0(0 оценок)
Ответ:
Следует отметить, что 1 условие выполняется во всех цепочках, а значит его можно не рассматривать.
Рассмотрим каждую комбинацию отдельно:
HDEE
2 условие - true
3 условие - true
4 условие - true
Подходит
HHAE
2 условие - true
3 условие - false(H на 2 месте)
HEAE
2 условие - true
3 условие - true
4 условие - true
Подходит
AHAH
2 условие - true
3 условие - true
4 условие - true
Подходит
AEAD
2 условие - true
3 условие - true
4 условие - true
Подходит
AEED
2 условие - false(E на 3 месте)
CAEH
2 условие - false(A не входит в список допустимых значений)
EHAD
2 условие - true
3 условие - false(E не входит в список допустимых значений)
CDEA
2 условие - true
3 условие - true
4 условие - false(A не входит в список допустимых значений)
ответ: 4
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота