В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
igorzarubin2006
igorzarubin2006
19.04.2022 03:21 •  Информатика

Напишите программу, в которой даны три действительных числа. Возвести в квадрат положительные числа и в четвертую степень - отрицательные c#

Показать ответ
Ответ:
azolin56745674
azolin56745674
13.10.2020 10:58

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           Console.WriteLine("Введите a:");

           a = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите b:");

           b = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите c:");

           c = Convert.ToDouble(Console.ReadLine());

           Console.Write("Результат: {0} , {1}, {2}", (a > 0) ? a * a : a * a * a * a,

               (b > 0) ? b * b : b * b * b * b, (c > 0) ? c * c : c * c * c * c);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота